December 17, 2018, 12:33:45 PM

Author Topic: s480 oiling issue  (Read 1141 times)

Offline rx7lee

s480 oiling issue
« on: February 17, 2015, 09:05:40 PM »
I'm having some issues with my new turbo. I was told I need to run a 4an feed and 12 an drain which I have. Frist start up and few miles went fine. after about 12 miles It started smoking so I pulled the exhuast off and there is oil leaking into the housing. I have to run a 45* fitting to clear my hotside and a 90* to get into the pan-the bung in the pan is as high as it can be. With the car level on Jack stands no oil comes out of the bung with the drain line off, but the car don't sit level on the ground. I can't get anymore angle on the drain line and the turbo is as high as it can go without hitting the hood so I have a bit of fall in line about 4 inches. Has anyone had to run a restrictor with a bw s480? The car does have a high flow oil pump.
:drive: 93 rx7

Offline Ruler_Mark

Re: s480 oiling issue
« Reply #1 on: February 17, 2015, 10:53:11 PM »
I have a -4an feed & 90* -12an return right off the drain to the front of the pan slightly angled down. No draining issues.  probably 3in of overall height on the return.

I would have the drain line drop straight into a bucket and see if anything comes out period you might have a bum turbo.
93 LS3 BWS475 The DigiCar

Offline rx7lee

Re: s480 oiling issue
« Reply #2 on: February 18, 2015, 12:45:39 AM »
Thanks for the idea. I sure hope it's not the turbo but there isn't much we Can do for the drain lines on these cars there just isn't much room
:drive: 93 rx7

Offline Ruler_Mark

Re: s480 oiling issue
« Reply #3 on: February 18, 2015, 11:22:27 AM »
forgot to add i have a s475 so very similar
93 LS3 BWS475 The DigiCar

Offline rx7lee

Re: s480 oiling issue
« Reply #4 on: February 18, 2015, 07:10:32 PM »
What do you do for venting your valve covers.my car will idle all day with out getting oil in the exhuast but after a few in boost pulls it puffs smoke
:drive: 93 rx7

Offline Ruler_Mark

Re: s480 oiling issue
« Reply #5 on: February 18, 2015, 11:06:24 PM »
What do you do for venting your valve covers.my car will idle all day with out getting oil in the exhuast but after a few in boost pulls it puffs smoke

I had the moroso venturi things on my downpipe for a while, when I went bumper exit I am now to a vented catchcan
93 LS3 BWS475 The DigiCar

Offline Fc3sluis

Re: s480 oiling issue
« Reply #6 on: November 14, 2018, 01:03:12 AM »
I had a similar issue and I noticed that the oil drain fitting I had wasnt as big as the Borg Warner hole, so I port matched it as much as I could basically to the gasket and funneled to make it flow better and my issue went away. And this was with a 10an fitting with almost no help from gravity.