November 17, 2019, 07:09:38 AM

Author Topic: UK RHD LS1 8.8 FD Gunnytron's build thread  (Read 92063 times)

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #300 on: June 02, 2015, 02:35:56 AM »
Hey gunnytron, where did you buy those relay+fuse boxes?

As above, they are jeep Cherokee boxes. I stumbled on a you tube vid about them and thought they looked spot on. I have de-wired a lot if the terminals but it's a pain in the arse. Ideally I would like new connectors but I can't find them anywhere. Probably best just to use the pig tails.
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Nfinitecc

  • Staged
  • Posts: 694
  • [URL=http://s919.photobucket.com/user/WCStanford/m
  • View Gallery
    • View Profile
Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #301 on: June 03, 2015, 10:04:37 PM »
You made a really nice mock drawing of your fuel system! Have you installed everything yet? If so how did it go?

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #302 on: June 04, 2015, 02:34:54 AM »
You made a really nice mock drawing of your fuel system! Have you installed everything yet? If so how did it go?

It's all in but I haven't run fuel through it yet.

I ended up having to change some of the connectors at the FPR to get the pipe angles I wanted. The only problem I have now is that the fuel pipe comes up by the bulkhead right where the heater pipes are so I need to bend the hardline.
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #303 on: June 13, 2015, 12:59:48 PM »
Fitted the bay harness again today after transferring everything over to the Jeep fuse/relay box.

Few issues:

1 - horn is on as soon as you attach the battery
2 - wiper motor doesn't work
3 - Sunroof doesn't work
4 - Electric mirrors don't work
5 - Heater blower doesn't work
6 - Windscreen washer motor doesn't work

I've not had a chance to see if there is something in common with these circuits yet so hopefully nothing to major.

I am sure the horns is a separate issue. I'm not sure what has changed since before, but I couldn't get them to work at all then so I guess that's progress :)

Here's my relay/fuse box layout
« Last Edit: January 06, 2018, 11:12:23 AM by Gunnytron »
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Exidous

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #304 on: June 13, 2015, 03:38:14 PM »
What are the dimensions on that box?
94 BB SBE LS1 Full Mamo top, MS3ProU with TC, RONIN 8.8 and another custom dual 2.5" stainless exhaust. Not too loud with the new resonators!

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #305 on: June 14, 2015, 12:44:06 PM »
What are the dimensions on that box?

I will let you know when I get around to measuring it.
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #306 on: June 14, 2015, 12:50:07 PM »
Progress to a point:

1 - horn is on as soon as you attach the battery - spent a while looking at this but I can't see why it isn't working. They are aftermarket horns so maybe I have to wire them differently?
2 - wiper motor doesn't work - this is getting on my nerves. I have power at the fuse, and motor socket but still no go.I can't believe the motor has failed since I last fitted the loom
3 - Sunroof doesn't work - sorted. I missed a couple of plugs
4 - Electric mirrors don't work - sorted. I missed a couple of plugs
5 - Heater blower doesn't work - Now this works to a point. It comes on but pulses on - off - on off, a bit like and indicator. No idea what's happening there.
6 - Windscreen washer motor doesn't work - sorted. I missed a couple of plugs

The only things I've changed since everything last worked was to remove the circuit relay as only one wire was attached to it (apart from the wire that goes to the EGI relay).
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #307 on: June 15, 2015, 02:51:17 AM »
What are the dimensions on that box?

H100mm W95mm L250mm

That's with both covers in and including any stickyouty bits like the cover release clip and the power stud.
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #308 on: June 15, 2015, 03:14:28 PM »
1 - horn is on as soon as you attach the battery - spent a while looking at this but I can't see why it isn't working. They are aftermarket horns so maybe I have to wire them differently?
2 - wiper motor doesn't work - FIXED, it was a bad earth
3 - Heater blower doesn't work - Now this works to a point. It comes on but pulses on - off - on off, still not sure on this one
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Tictakman

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #309 on: June 15, 2015, 04:24:15 PM »
I bet ya halfspec would be able to help... Id like to remove some of the unused fuses in my bay this time around.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #310 on: June 15, 2015, 04:51:11 PM »
I bet ya halfspec would be able to help... Id like to remove some of the unused fuses in my bay this time around.

No doubt. I want to try plugging the sensor that is on the AC matrix in as that is the only thing I can think of that has changed. Failing that I may have to ask said expert for help :)
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline halfspec

  • Top Fuel
  • Location: Starkville, MS
  • Posts: 2234
  • Resistance Is Futile
  • View Gallery
    • View Profile
    • HalfSpec.com
Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #311 on: June 18, 2015, 09:09:39 AM »
The blower's electrical system in the FD is pretty dead simple. You can read the diagram on Z68 of your FSM bible. It consists of a relay, fuse, resistor, position switch, and the actual blower motor. The relay turns on with switched power from the ignition switch. I wouldn't point my finger at the ignition switch otherwise, a lot of other things would be pulsing in the car. The relay could have a bad ground, but your pulses would be accompanied by an audible relay click. Easy to check. Ground for the blower resistor is right below the passenger A pillar. The fuse shouldn't be an issue. The resistor could be an issue as it's the #1 thing to fail in the system, just from my observations of people PMing me and working problems down to the resistor, however, I've never heard of a case that would pulse the motor as the resistor is just a chunk of metal and ceramic and can't change its resistance on the fly unless it's got some kind of crazy thermal runaway thing going on. I suppose the motor could possibly be broken enough to pulse. I'm not sure how the FD's blower motor is constructed, nor am I a motor expert, but I would imagine it's just a simple DC brush motor. I haven't heard of brushes needing to be replaced on the blower motor, but perhaps that could cause the issue? The position switch is simple/mechanical. I don't see how that could pulse the motor. Finally you have the blower motors ground, which could be improperly grounded. It's in the passenger kick panel.

Hope that helps
Lane

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #312 on: June 20, 2015, 01:49:00 PM »
The blower's electrical system in the FD is pretty dead simple. You can read the diagram on Z68 of your FSM bible. It consists of a relay, fuse, resistor, position switch, and the actual blower motor. The relay turns on with switched power from the ignition switch. I wouldn't point my finger at the ignition switch otherwise, a lot of other things would be pulsing in the car. The relay could have a bad ground, but your pulses would be accompanied by an audible relay click. Easy to check. Ground for the blower resistor is right below the passenger A pillar. The fuse shouldn't be an issue. The resistor could be an issue as it's the #1 thing to fail in the system, just from my observations of people PMing me and working problems down to the resistor, however, I've never heard of a case that would pulse the motor as the resistor is just a chunk of metal and ceramic and can't change its resistance on the fly unless it's got some kind of crazy thermal runaway thing going on. I suppose the motor could possibly be broken enough to pulse. I'm not sure how the FD's blower motor is constructed, nor am I a motor expert, but I would imagine it's just a simple DC brush motor. I haven't heard of brushes needing to be replaced on the blower motor, but perhaps that could cause the issue? The position switch is simple/mechanical. I don't see how that could pulse the motor. Finally you have the blower motors ground, which could be improperly grounded. It's in the passenger kick panel.

Hope that helps
Lane

Thanks for the input Lane. I found out what the problem is and I am a little ashamed.
I noticed that when I touched certain electrical connectors the fan worked fine but it was eratic. After a while I noticed that the dash support was earthing on the gear stick. When I leant over the dash to touch the connectors I broke the earth contact  :banghead:

So all sorted now and I can finally finish wrapping the loom.  8)
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.

Offline Donthitme

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #313 on: June 20, 2015, 04:51:57 PM »
Fine sand then put some dielectric grease on all your grounds(earth) so you wont have problems down the road.

Offline Gunnytron

Re: UK RHD LS1 8.8 FD Gunnytron's build thread
« Reply #314 on: June 30, 2015, 04:34:33 PM »
Front loom is pretty much in and finished except for the horn. I left a few cables in for fan control which I will sort later.

Started sound proofing the footwells. I decided to cover more critical areas rather than every square inch. It's a balance between weight/cost and dampening.



« Last Edit: January 06, 2018, 11:13:17 AM by Gunnytron »
http://www.norotors.com/index.php?topic=12880.0
FD, LS1 running 220 3.90 Trickflow heads, Comp Ultra-gold Arc 1.72 Rockers, 7.550 BTR Pushrods, BTR Stage II NA Cam 227/234 .614"/.576" 113+2, ARP Head Bolts, BTR Platinum Springs, Ported FAST 90, NW 90mm TB, FAST 60lb Injectors, Textralia Clutch/Flywheel, T56, Cobra 8.8, 31 spline, trac-loc 3.55 Diff, Holley HP EFI, Racelogic TC.